info@unhackable.org Phone: +877 547 3638

CVE-2016-0800: DROWN OpenSSL vulnerability / SSLv2 disabled

OpenSSL Security Advisory [1st March 2016] ========================================= NOTE: With this update, OpenSSL is disabling the SSLv2 protocol by default, as well as removing SSLv2 EXPORT ciphers. We strongly advise against the use of SSLv2 due not only to the issues described below, but to the other known deficiencies in the protocol as described at https://tools.ietf.org/html/rfc6176 […]

Read More »

CVE-2016-0739: libssh 0.1 and later vulnerable

======================================================================= == Subject: Weakness in diffie-hellman secret key generation == == CVE ID#: CVE-2016-0739 == == Versions: All versions of libssh 0.1 and later == == Summary: Due to a bug in the ephemeral secret key generation for == the diffie-hellman-group1 and diffie-hellman-group14 == methods, ephemeral secret keys of size 128 bits are == generated, […]

Read More »

glibc arbitrary code execution vulnerability (CVE-2014-0475 and CVE-2014-5119)

Two new vulnerabilities deemed as Important severity have been discovered and patched in glibc libraries. In order for updates to take effect, a service restart for all daemons with a glibc dependency must occur. This includes, but is not limited to: Apache, MySQL Mail S ervices, SSH, etc. ===================================================================== Red Hat Security Advisory Synopsis: Important: […]

Read More »

OpenSSL Still vulnerable, fix CVE-2012-2110 not sufficient!

It was discovered that the fix for CVE-2012-2110 released on 19 Apr 2012 and referenced in this post on unhackable, was not sufficient to correct the issue for OpenSSL 0.9.8. Please see http://www.openssl.org/news/secadv_20120419.txt for details of that vulnerability. This issue only affects OpenSSL 0.9.8v. OpenSSL 1.0.1a and 1.0.0i already contain a patch sufficient to correct […]

Read More »

OpenSSL Vulnerabilities – CVE-2012-2110, CVE-2006-7250, CVE-2012-1165

Summary: An application using OpenSSL could be made to crash or run programs if it opened a specially crafted file. Software Description: – openssl: Secure Socket Layer (SSL) cryptographic library and tools Details: It was discovered that OpenSSL could be made to dereference a NULL pointer when processing S/MIME messages. A remote attacker could use […]

Read More »

Vulnerabilities discovered in OpenSSL <0.9.8u and 1.x before 1.0.0h

Multiple vulnerabilities has been found and corrected in openssl: The implementation of Cryptographic Message Syntax (CMS) and PKCS #7 in OpenSSL before 0.9.8u and 1.x before 1.0.0h does not properly restrict certain oracle behavior, which makes it easier for context-dependent attackers to decrypt data via a Million Message Attack (MMA) adaptive chosen ciphertext attack (CVE-2012-0884). […]

Read More »

Vulnerability discovered in GnuTLS < 2.12.17

A vulnerability has been found and corrected in GnuTLS: gnutls_cipher.c in libgnutls in GnuTLS before 2.12.17 and 3.x before 3.0.15 does not properly handle data encrypted with a block cipher, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) via a crafted record, as demonstrated by a crafted […]

Read More »

libpng security vulnerability allows execution of arbitrary code

The libpng packages contain a library of functions for creating and manipulating PNG (Portable Network Graphics) image format files. A flaw was discovered in libpng that could result in libpng trying to free() random memory if certain, unlikely error conditions occurred. If a carefully-crafted PNG file was loaded by an application linked against libpng, it […]

Read More »